UltraBranch Troubleshooting Guide

Configuring Browser Security Settings

UltraBranch uses TLS encryption to encode the communication between your browser and UltraBranch to ensure your privacy and security. Alaska USA requires TLS version 1.0 or above, which is replacement for previous SSL versions.

Most browsers come with these security features enabled. If you are unable to connect to UltraBranch, follow the steps listed below to ensure that your Browser is properly configured to use these security features.

Other Browser not listed in this Guide

If you are using a web browser not listed in this guide, please consult the documentation that came with your browser or contact the manufacturer to learn how to enable TLS version 1.0 or security or greater. Browsers that do not support TLS 1.0 or greater will not function with UltraBranch.