Frequently Asked Questions

Search FAQs:       
Only select records are listed below. View all FAQs

UltraBranch Compatibility Issues

Browser Version Requirements

In order to access UltraBranch via the Internet, you need a browser that supports web standards including HTML 4, SSLv3, JavaScript and CSS.

Alaska USA recommends using the latest versions of Firefox, Internet Explorer, Chrome, or Safari. Other browsers that support web standards should work with UltraBranch, but are not specifically tested by Alaska USA.

For both compatibility and security, Alaska USA recommends upgrading to the latest version of your browser, and staying current on all patches for both your browser and operating system.

<< Back to previous page | Return to FAQ Index